SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Search Forums

Showing results 1 to 25 of 498
Search took 2.75 seconds.
Search: Posts Made By: stevestar99
Forum: S-Series Tech 11-16-2013, 10:39 AM
Replies: 6
Views: 491
Posted By stevestar99
Re: question about my instrument cluster

If the speed-o is working, then the odometer should be working ...

Sounds like your OLD cluster was in better shape than the one you just put in ..
Forum: S-Series Tech 11-16-2013, 10:19 AM
Replies: 1,257
Views: 480,251
Posted By stevestar99
Re: how many miles do you have on your saturn?

95' SL1... 271,000.... New head at 250k.. (bent valve)

My new job commute has me putting on a 100 miles a day now..

35 mpg.. Runs, looks great for age and miles...
Forum: S-Series Tech 11-16-2013, 05:06 AM
Replies: 2
Views: 457
Posted By stevestar99
95 SL1 cooling fan stuck ON, not the relay

Anybody got the pdf. wiring diagram for the cooling fan circuit?.... The relay is being held down by signal and is not a contact wield.. Even after the engine is shut down it stays ON.. Yes, the SES...
Forum: S-Series Tech 04-22-2013, 08:03 PM
Replies: 7
Views: 559
Posted By stevestar99
Re: 95' SL1... Throwing 11, trans-axle code

Thanks again Old Nut... Will Do... I'll get back to you later (next week end).. let you know what I found,...


Steve...
Forum: S-Series Tech 04-22-2013, 07:55 PM
Replies: 7
Views: 559
Posted By stevestar99
Re: 95' SL1... Throwing 11, trans-axle code

Thanks.. Old nut.. I've had trouble before with the trany fuse sockets becoming tarnished.. But shouldn't the trany be acting up if I had a "real" problem ?...
Forum: S-Series Tech 04-22-2013, 07:35 PM
Replies: 7
Views: 559
Posted By stevestar99
Re: 95' SL1... Throwing 11, trans-axle code

OK, it's a #25... NO TCC.. What's that.. NO torque converter control ?

What's up with that ?.. the car is running like nothing is wrong..

Steve
Forum: S-Series Tech 04-22-2013, 07:19 PM
Replies: 7
Views: 559
Posted By stevestar99
Re: 95' SL1... Throwing 11, trans-axle code

Thanks Fectch..

Now I get it... I'v got to read the "Coolant Light"..

I'm going outside right now.. to get the rest of the codes...

See ya... Steve
Forum: S-Series Tech 04-22-2013, 07:10 PM
Replies: 24
Views: 1,399
Posted By stevestar99
Re: 95 SL1 tranny woes

Never had that issue with my 95' SL1, but when I've had other trany probems , it's aways been "electric".. Bad fuse connectors... I'd check your harness from front to back.. This trany goes crazy if...
Forum: S-Series Tech 04-22-2013, 06:38 PM
Replies: 7
Views: 559
Posted By stevestar99
95' SL1... Throwing 11, trans-axle code

Hey Guys... My 95 has just started flashing a #11 code.. When I start out in the morning, NO SES light.. After about a half hour on the road... The SES light comes on and stays on... When it pops on,...
Forum: S-Series Tech 11-10-2012, 06:32 PM
Replies: 2
Views: 859
Posted By stevestar99
Re: New head, idle low

Thanks Rock... That's what I was thinking, but it's nice that you confirmed it...
Forum: S-Series Tech 11-10-2012, 05:10 PM
Replies: 2
Views: 859
Posted By stevestar99
New head, idle low

Hey, guys.. I did a head job a couple months back.. And it came out pretty good.. The old 95 sl1 has 260k on it, so I'm pretty sure the compression isn't up to snuff.. The only problem I'm having...
Forum: S-Series Tech 10-16-2012, 06:24 AM
Replies: 2
Views: 710
Posted By stevestar99
Re: Just bought 95 sl1 to have trans problems

Sorry, friend.. It's too late now.. Your looking at a new/rebuilt engine.. Sell it for scrape.. What a shame.. a 95' with only 43k on it.. Mine has 260k on it.. YOU SHOULD HAVE COME HERE FIRST,...
Forum: S-Series Tech 10-03-2012, 11:31 PM
Replies: 5
Views: 1,064
Posted By stevestar99
Re: Turn key, seems normal, doesn't start

Next time it does it, try running the gear shifter up and down from Park to Drive a couple of times..
Forum: S-Series Tech 10-02-2012, 08:47 PM
Replies: 11
Views: 1,649
Posted By stevestar99
Re: Car randomly turns off

The next time it does it.. Try to take note of what other electrical failures are occurring at the same time.. That way you have a common denominator to work from
Forum: S-Series Tech 10-02-2012, 08:29 PM
Replies: 23
Views: 6,645
Posted By stevestar99
Re: 98 SL2: Loss of power, Misfire, stumbling, 4k rev limit, timing chain related?

I jumped a chain by one tooth once, by stomping on the throttle hard..The chain was sloppy at the time when I did it... It wasn't Saturn but it was a DOHC and ended up destroying the valves one side...
Forum: S-Series Tech 09-30-2012, 05:33 PM
Replies: 3
Views: 1,235
Posted By stevestar99
Re: 95 Saturn SL1 cranking problems

A real "quicky" way is to : Pull a plug, connect it back to plug wire, lay it up on the valve cover and crank.. Do see a spark? Do you smell gas?.. It gives you a place to start..
Forum: S-Series Tech 09-30-2012, 04:29 PM
Replies: 4
Views: 538
Posted By stevestar99
Re: Installing Manual Fan Switch - Switch Type Question

Hey, DYIguy stole my idea.. Not really (just joken), his is for the ETCS, mine is for the 95 temp sensor.. And his is much more elaborate than mine.. Good job DYI...And thanks, I just noticed that...
Forum: S-Series Tech 09-29-2012, 12:07 PM
Replies: 4
Views: 538
Posted By stevestar99
Re: Installing Manual Fan Switch - Switch Type Question

Ya, it should be fine.. your only powering a relay not the fan itself.. The only thing that I would be concerned about is to make sure the wire isn't pitched or snagged on some sharp piece of metal
Forum: S-Series Tech 09-29-2012, 11:57 AM
Replies: 18
Views: 2,460
Posted By stevestar99
Re: Got new starter put on but STILL starting probs.

All the grounding for the solenoid and starter comes through the engine block.. When you installed the new started, did you clean off the mount of grease and corrosion.. Did you check/clean the...
Forum: S-Series Tech 09-29-2012, 11:34 AM
Replies: 18
Views: 2,460
Posted By stevestar99
Re: Got new starter put on but STILL starting probs.

Ok, it sounds like a bad solenoid line... To confirm it and for an emergence start... Get yourself a piece of wire.. long enough to reach from the POS battery post to the starter solenoid post.. Rap...
Forum: S-Series Tech 09-29-2012, 11:11 AM
Replies: 18
Views: 2,460
Posted By stevestar99
Re: Got new starter put on but STILL starting probs.

Do hear the solenoid clicking on the starter ? There are two 12v B+ lines to the starter.. One is the main, high amp line that actually supplies the juice to turn the motor and the other one is for...
Forum: S-Series Tech 09-29-2012, 10:24 AM
Replies: 2
Views: 527
Posted By stevestar99
Re: 95' SL1 head job

Ya, I'll change that.. No ,I guess I won't.. Too late for an edit..

Anyway that's Richpin not Rippin... LOL
Forum: S-Series Tech 09-29-2012, 10:06 AM
Replies: 2
Views: 527
Posted By stevestar99
95' SL1 head job

Hey guys, did a head job last week for the first time in about 20 years.. And got loads of good info before starting.. Rippin's You-tubes were the most helpful.. Watching someone else doing it is...
Forum: S-Series Tech 09-10-2012, 08:16 AM
Replies: 3
Views: 394
Posted By stevestar99
Can you ID this SOHC head ?

Hey guys, I need some help... I ordered a "1995" head and this is what I got.. It's clearly not a 95' head because it's missing the "temp sensor" port.. But if I were to drill and tap the spot were...
Forum: S-Series Tech 08-09-2012, 09:39 PM
Replies: 8
Views: 1,284
Posted By stevestar99
Re: 95' SOHC... Oil Pump ???

Thanks Madpoege for the input... I thought I had one and went up under the engine to put it in AND IT"S THE WRONG SENDER !!!.. Anyway, I think I might have been chasing a red heiring... I dump the...
Showing results 1 to 25 of 498

 
Forum Jump

All times are GMT -4. The time now is 12:28 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.