SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Search Forums
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Showing results 1 to 17 of 17
Search took 0.04 seconds.
Search: Posts Made By: Kaspar7
Forum: S-Series Tech 10-07-2017, 04:22 PM
Replies: 21
Views: 475
Posted By Kaspar7
Re: 19999 SW1 temp gauge behaving oddly after radiator replacement

Thanks for the great pic and the description of how to see the pump. I read that there were 3 10mm bolts on the pulley and 6 on the pump. I peeked in just the right direction and sway where it is....
Forum: S-Series Tech 10-07-2017, 04:12 PM
Replies: 21
Views: 475
Posted By Kaspar7
Re: 19999 SW1 temp gauge behaving oddly after radiator replacement

Thanks! That's exactly what I was doing! I thought there might be something else but I guess that's it!
Forum: S-Series Tech 10-05-2017, 07:11 PM
Replies: 1
Views: 211
Posted By Kaspar7
99 SW1 - Possibly useful info

I somehow lost the bolt that holds the fan to the radiator - despite putting it into a magnetic parts dish as soon as I took it out! Couldn't find anything to fit; the last one I had like that(old...
Forum: S-Series Tech 10-05-2017, 06:54 PM
Replies: 21
Views: 475
Posted By Kaspar7
Re: 19999 SW1 temp gauge behaving oddly after radiator replacement

How do I bleed the cooling system to be sure all air is out?
Forum: S-Series Tech 10-05-2017, 06:51 PM
Replies: 21
Views: 475
Posted By Kaspar7
Re: 19999 SW1 temp gauge behaving oddly after radiator replacement

All I knew was that the head of the bolt fit a 10mm socket. Didn't know the bolt diameter, thread size or length. BUT, I located one of the blind-nut clips that was left over from the radiator job ...
Forum: S-Series Tech 10-05-2017, 04:11 PM
Replies: 21
Views: 475
Posted By Kaspar7
Re: 19999 SW1 temp gauge behaving oddly after radiator replacement

it's running really hot now; went clear up to the red zone and the Hi-Temp light came on. Fan isn't coming on. Bought a new fan motor and replaced that. But now I can't find that ONE bolt that holds...
Forum: S-Series Tech 10-05-2017, 04:07 PM
Replies: 21
Views: 475
Posted By Kaspar7
Re: 19999 SW1 temp gauge behaving oddly after radiator replacement

Me, too. But why is there no dealership? I need parts.
Forum: S-Series Tech 10-05-2017, 04:05 PM
Replies: 21
Views: 475
Posted By Kaspar7
Re: 19999 SW1 temp gauge behaving oddly after radiator replacement

Thanks, but I'm so old-school that I just bought a candy thermometer for $5 at Kroger. I'll open the recovery tank, start the engine and watch the temperature until the fan starts spinning. I already...
Forum: S-Series Tech 10-05-2017, 03:56 PM
Replies: 21
Views: 475
Posted By Kaspar7
Re: 19999 SW1 temp gauge behaving oddly after radiator replacement

When the Tardis landed that year, we spotted an ancient Saturn vehicle. We were intrigued, so we brought it back to 2107 just for grins. It needs a bit of work. :D :d :D
Forum: S-Series Tech 10-05-2017, 12:45 PM
Replies: 21
Views: 475
Posted By Kaspar7
Re: 19999 SW1 temp gauge behaving oddly after radiator replacement

As soon as I figure out where the water pump is, exactly, I'll have a look for any leakage. ECTS is fine, replaced 23 months ago. the DTC for it cleared as soon as I had a good ECTC in there (the...
Forum: S-Series Tech 10-05-2017, 12:40 PM
Replies: 21
Views: 475
Posted By Kaspar7
Re: 19999 SW1 temp gauge behaving oddly after radiator replacement

Replacing the cap seems like a smart idea. Don't have tool/know-how to test the pressure. when the car gets really hot (>7/8) some coolant gets past the recovery tank cap.

I replaced the ECTS 2...
Forum: S-Series Tech 10-05-2017, 09:23 AM
Replies: 21
Views: 475
Posted By Kaspar7
19999 SW1 temp gauge behaving oddly after radiator replacement

First, I bought the car used about 3 months ago and it didn't come with maintenance records. It has 212K miles. After a few weeks, it started losing a little coolant. There was a small leak on the...
Forum: S-Series Tech 08-04-2017, 09:37 AM
Replies: 2
Views: 142
Posted By Kaspar7
Re: 99 SW1 Tailgate rattle

If I can't find the actual parts to fix it, I have some high-density foam that I can put in at the trouble spots but either way, this rattle must be silenced! The car has so many rattles that I need...
Forum: S-Series Tech 08-04-2017, 09:32 AM
Replies: 2
Views: 142
Posted By Kaspar7
99 SW1 Tailgate rattle

Hi! The tailgate of the wagon makes several rattling noises when idling or driving. The four rubber pieces that should damp any vibrations seem to be softened by age. Is there any chance of finding...
Forum: S-Series Tech 08-04-2017, 09:26 AM
Replies: 3
Views: 206
Posted By Kaspar7
99 SW1 Center High-Mount Brake Light bulb replacement

Can anyone point me to a thread, etc. that shows (with pictures that are actually still visible!) exactly how to remove and replace the center high mount brake light bulbs in my 1999 SW!? Or possibly...
Forum: S-Series Tech 06-10-2017, 04:11 PM
Replies: 17
Views: 618
Posted By Kaspar7
Re: new radiator time!

I have a 1999 SW1. when I looked up these lines on Amazon, I was asked about the transmission. It said the AC/Delco #21031306 and #21031307 lines were a match if my car had the MP6 automatic...
Forum: S-Series Tech 06-10-2017, 03:45 PM
Replies: 1
Views: 155
Posted By Kaspar7
99 SW1 has rough idle & P0301 code

1999 SW1 w/200K miles. Idles rough when cold but improves after warm up (when temp gauge is reading just over 1/4.)

When you connect an OBD-II reader and the engine is cold, you get a P0301 code....
Showing results 1 to 17 of 17

 
Forum Jump

All times are GMT -5. The time now is 11:26 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.