SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Search Forums
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Showing results 1 to 25 of 67
Search took 0.13 seconds.
Search: Posts Made By: chevyjoe
Forum: S-Series Tech 05-22-2010, 09:31 PM
Replies: 7
Views: 3,824
Posted By chevyjoe
Re: Transmission for Saturn SL2

about a month ago I put a 94 MP3 into an 01 SL2... it IS possible. The only thing I modified were the seal retainers that are on the 01 1/2 shafts had to be removed. No probs, no leaks and the cruise...
Forum: S-Series General 05-18-2010, 04:11 PM
Replies: 9
Views: 752
Posted By chevyjoe
Re: A few Questions

^^^ +1, damn stealerships
Forum: S-Series General 05-18-2010, 04:05 PM
Replies: 27
Views: 1,555
Posted By chevyjoe
Re: What RPM do you shift at?

As high as the SC2 and SL2's would:D.

They both got nice chirps going into 2nd, and nothing broke!

94 SC2... bone yard and 01 SL2, sold a few days ago and the latest SC2 is auto. I got sick of...
Forum: S-Series General 05-17-2010, 04:09 AM
Replies: 5,504
Views: 2,248,247
Posted By chevyjoe
Re: What did you do to your S-Series today...

I've only had the '01 SC2 for a few days, but...

NGK copper plugs... the old ones were really bad. surprised she ran so well... two were gapped at .085 and two were at .065, just worn and never...
Forum: S-Series General 05-11-2010, 10:00 PM
Replies: 25
Views: 1,397
Posted By chevyjoe
Forum: S-Series Tech 04-19-2010, 08:09 PM
Replies: 18
Views: 1,945
Posted By chevyjoe
Re: Clutch - Stiff Shifting

So much for ASE cert :dizzy:
Forum: S-Series Tech 04-19-2010, 03:29 PM
Replies: 50
Views: 4,488
Posted By chevyjoe
Re: Bosch Platinum Plugs - SL1 runs great!

Dude, thanks for digging up this thread. I never even heard of this waste spark.
So, just go w/ the recommended # plug? What is it, big brother is watching me here at work and I gotta limit my...
Forum: S-Series General 04-15-2010, 04:54 AM
Replies: 19
Views: 1,217
Posted By chevyjoe
Re: '01 SL2 temp... may need thermostat

Thanks man, THAT's what I was looking for, but w/ no luck...
This is me...

Vehicle: Sedan (SL2)
Year: 2001
Build Date: 2001-01-04

But with the low month/day, which is which? Prolly Jan 4,...
Forum: S-Series General 04-15-2010, 04:37 AM
Replies: 53
Views: 2,562
Posted By chevyjoe
Re: eBay find - 1991 SL1 # 8

Come on Jay Leno, snag this beauty up. I can see the jet engine in her already.:D
Forum: S-Series Mods 04-14-2010, 08:25 PM
Replies: 45
Views: 3,830
Posted By chevyjoe
Re: Some performance increase...

Ha, my bad. knew I should've added the 300 lb air cylinders, just incase this happened. Didn't wanna reveal too much. Oh and worry not, cause the discharge of the air cylinder has additional...
Forum: S-Series Mods 04-14-2010, 07:56 PM
Replies: 45
Views: 3,830
Posted By chevyjoe
Re: Some performance increase...

Hang on... I got it.
1. Buy a generator.
2. Place said generator in trunk.
3. Buy a shop vac, plug in to running generator, turn on shop vac.
4. Have said shop vac suck on exhaust pipe.
5. Now...
Forum: S-Series General 04-14-2010, 04:19 PM
Replies: 19
Views: 1,217
Posted By chevyjoe
Re: '01 SL2 temp... may need thermostat

Well, can't edit this one soooooooooo

All's I see is on the drivers door it states 01 01 as the date, but I think that's more for federal safety and security regulated things and not necessarily...
Forum: S-Series General 04-14-2010, 03:59 PM
Replies: 19
Views: 1,217
Posted By chevyjoe
Re: '01 SL2 temp... may need thermostat

Alright , been searching for a while now. NO LUCK!

Well the sequential # is 291052 if that helps anyone. I'd put the whole VIN here, but honestly I've seen you watching me and it's freaking me...
Forum: S-Series General 04-14-2010, 02:50 PM
Replies: 19
Views: 1,217
Posted By chevyjoe
Re: '01 SL2 temp... may need thermostat

Well, 3/8 it is.
I changed the ECTS and t-stat (and PCV valve too) last night.
Went for a drive after... got the low coolant light... pulled in to Kmart and topped her off and good to go. And yes,...
Forum: S-Series Tech 04-14-2010, 02:27 PM
Replies: 12
Views: 1,615
Posted By chevyjoe
Re: 98 digital odometer bulb

If you gat a new cluster (used), there may be more bulbs out than you've got now. In other words, you know what you've got, you don't know what you'll get. Then there's the milage discrepency.
It...
Forum: S-Series General 04-13-2010, 04:10 PM
Replies: 19
Views: 1,217
Posted By chevyjoe
Wrench Re: '01 SL2 temp... may need thermostat

Ha I must have a pre mid year '01 SL2... I of course have the resin one. Eh oh well, easy job :usa:

I ALWAYS use the universal coolant whenever I do stuff with cooling systems.

Now to check...
Forum: S-Series General 04-13-2010, 12:27 AM
Replies: 19
Views: 1,217
Posted By chevyjoe
Re: '01 SL2 temp... may need thermostat

Yeah I suppose I could drive around viewing live data, but pointless if the ECTS needs changed. I imagine it's good... doesn't wander or anything.

Just hit 114k on her too, so I guess the t-stat...
Forum: S-Series General 04-12-2010, 01:38 AM
Replies: 1
Views: 355
Posted By chevyjoe
"01 SL2 shifting... will this lube work?

Ok I got some Hoppe's "the gun care people" Dri-Lube... a dry lubricant for all mechanisms.

There that's what the can says. They didn't have the mica, so I figured I'd try this stuff. Any of you...
Forum: S-Series General 04-12-2010, 01:26 AM
Replies: 19
Views: 1,217
Posted By chevyjoe
Re: '01 SL2 temp... may need thermostat

Yeah, that's what I've been used to in my vehicles. The only time I cranked the heat (temp and fan speed) was when I was testing the car b4 buying it.
I just figured this was normal operating temp....
Forum: S-Series General 04-11-2010, 07:31 PM
Replies: 19
Views: 1,217
Posted By chevyjoe
'01 SL2 temp... may need thermostat

Ya know Old Nuc, just when I thought I was done w/ my '01 SL2 :D ...

My temp never goes above 1/4... time to do a thermostat I guess... also, any way to find out if I've got the brass ECTS w/o...
Forum: S-Series Tech 04-05-2010, 07:43 PM
Replies: 11
Views: 967
Posted By chevyjoe
Re: ECTS replace gone bad need help

I was gonna ask if these were non-interference engines... nevermind.:us:
Forum: S-Series Tech 04-05-2010, 07:14 AM
Replies: 4
Views: 584
Posted By chevyjoe
Re: '01 SL2 W/ '93 MP3 shifting issues

Ya know what, I think you're right. I think it's the one for in/out movement (whatever the tech term is for that one).

I'm gonna have to read up on using that mica lubricant. I checked all of the...
Forum: S-Series Tech 04-04-2010, 01:51 PM
Replies: 4
Views: 584
Posted By chevyjoe
Re: '01 SL2 W/ '93 MP3 shifting issues

Yes, it seems that way to me anyways. I understand the leverage the shifter provides, something just doesn't feel right.
Forum: S-Series Tech 04-04-2010, 06:47 AM
Replies: 4
Views: 584
Posted By chevyjoe
Roll Eyes '01 SL2 W/ '93 MP3 shifting issues

Ok, I just unhooked the cables at the tranny.

Yes, the cable for side to side movement at the shifter and pulls the rod in and out at the tranny could probably use some lubrication (mica?).The...
Forum: S-Series Tech 04-03-2010, 11:22 AM
Replies: 3
Views: 678
Posted By chevyjoe
Showing results 1 to 25 of 67

 
Forum Jump

All times are GMT -5. The time now is 01:11 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.