SaturnFans.com Forums

SaturnFans.com Forums (http://www.saturnfans.com/forums/index.php)
-   S-Series Tech (http://www.saturnfans.com/forums/forumdisplay.php?f=39)
-   -   New Engine and radiator.. Temp gauge input needed!!!! (http://www.saturnfans.com/forums/showthread.php?t=27627)

sideout303 11-25-2003 12:25 PM

New Engine and radiator.. Temp gauge input needed!!!!
 
I'll TRY to keep this as short as possible, but would like some input/info.. PLEASE! :)

Car:

1995 Saturn SL2
REMANUFACTURED Engine installed by Saturn Dealer
NEW Radiator
121,000 miles on odometer

Old Situation
**********

Had bad oil fouling on 2nd and 3rd plug and small oil leaks around the head.

Had the radiator flushed/filled and new thermostat put in as was experienced HIGH temp gauge readings. Turned out radiator was cracked (small leaks as well and low coolant light was coming on). Had the radiator replaced.

8 months later was filling up the coolant reservoir roughly every 1 1/2 weeks (low coolant light). Didn't see leaks until short time after having the shop look at it. Turns out my engine was getting WAY too hot and causing pressue buildup in radiator.

Decided to have engine replaced and have radiator swapped out under warranty afterwards.

Current Situation
**************

Saturn replaced the engine with a REMANUFACTURED one from their dealership. The next day i had a NEW radiator put in as the one from 8 months ago was leaking/cracked again due to the old engine heating up/building up pressure..


My questions/concerns:
*******************

With having the Radiator replaced/Engine replaced/New thermostat, my car STILL hit's 3/4 way mark on the Coolant Temp Gauge, but the fan kicks on.

Took it back to the dealer to check the Coolant Temperature Sensor. They hooked it up to the diagnostics machine. No codes came back reading abnormal and from what i remember, he said it's working as designed where the fan kicks on at 226 degrees (from what i remember)

Is this normal?????

Driving on the interstate the needle sits at the 1/2 way mark, BUT coming to a stop at a light or in traffic it'll slowly go to the 3/4 way mark and the fan will kick on. Coasting down a hill (no acceleration from my foot being on the pedal), the gauge will drop between 1/4 and 1/2 before i step on the gas again.

Is there something else i need to look at/get replaced or is this REALLY normal for this model year Saturn????

I just can't remember when i bought it used the temp gauge going to the 3/4 way mark until the engine starting having problems. I figured having the engine AND radiator replaced the car would sit around 1/4 way mark if at worse case 1/2....

Thoughts or ideas would be greatly appreciated...

eljefino 11-25-2003 01:35 PM

This is normal for your model year. It's irritating and unnerving which is why this B.B.S. has a section about overriding the fan to get it to turn on more.

sideout303 11-25-2003 01:40 PM

[QUOTE][i]Originally posted by eljefino [/i]
[B]This is normal for your model year. It's irritating and unnerving which is why this B.B.S. has a section about overriding the fan to get it to turn on more. [/B][/QUOTE]

Yes, this is VERY unnerving as i don't wanna blow another radiator or have other problems..

I thought about having the ECTS (Engine coolant temp sensor) replaced.. I just don't know why i'd STILL be experiencing the temp gauge issue AFTER have the engine and radiator replaced.

Not remembering this being an issue when i first bought the car is also odd. Seeing as the engine was going on it, yeah, i could see it being an issue, but after replacing the whole engine and radiator.. weird!

thanks for the info though... makes me "somewhat" at ease! hehehe

wolfman 11-25-2003 08:50 PM

3/4 gauge reading for the fan "ON" in a 95' model year is NORMAL. It should shut back down at just below the 1/2 mark. If you don't like the factory settings, see the "How To" section for EASY instructions on how to install an manual switch for less than $5 that'll give you full control while maintaining the factory automatic control as well.

amazinghl 11-25-2003 09:09 PM

Re: New Engine and radiator.. Temp gauge input needed!!!!
 
[QUOTE][i]Originally posted by sideout303 [/i]
[B]Is this normal?????

Driving on the interstate the needle sits at the 1/2 way mark, BUT coming to a stop at a light or in traffic it'll slowly go to the 3/4 way mark and the fan will kick on. Coasting down a hill (no acceleration from my foot being on the pedal), the gauge will drop between 1/4 and 1/2 before i step on the gas again.
[/B][/QUOTE]


What's how my car is.

Twin_Cam 11-25-2003 11:41 PM

Perfectly normal? Yes. Annoying? Oh yes!


All times are GMT -5. The time now is 10:10 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.