SaturnFans.com Forums

SaturnFans.com Forums (http://www.saturnfans.com/forums/index.php)
-   L-Series General (http://www.saturnfans.com/forums/forumdisplay.php?f=69)
-   -   2004 L300 audio wiring (http://www.saturnfans.com/forums/showthread.php?t=232710)

627 10-05-2017 05:39 PM

2004 L300 audio wiring
 
I've got a 2004 L300 that's in great shape and can probably last me another several years, but I'm itching to swap out the factory head unit with one that does Bluetooth.

My only problem is that this is one of the models with the advanced audio package with the factory amp and for whatever reason I can't find a definitive answer as to whether I can just use a normal harness or if there's any different harness or a bypass or other special wiring concerns I need to be aware of to make the thing work. I'd like to assume that since I haven't seen any straight answers I'm able to get the normal harness and be just fine, but measure twice, cut once, etc.

Can anyone confirm this for me? I've provided model numbers for the aftermarket parts I'm looking at below if that's any help.

Harness that seems to be right at least for the base model: Metra 70-2002
Aftermarket head unit: Pioneer MVH-X370BT

soulsurvives 10-05-2017 06:01 PM

Re: 2004 L300 audio wiring
 
I put an Alpine with Bluetooth in my wife's L300 and it works great. She has the premium stereo and on star. If I remember correctly I got whatever free harness that came with the stereo as I got it from Crutchfield. Don't forget to hook up the factory amp turn on wire, I didn't at first and thought I was in trouble LOL.

02 LW300 10-05-2017 10:46 PM

Re: 2004 L300 audio wiring
 
In 2002 the premium sound system used a piggyback amp system. The plugs are the same and you can use the amp or disconnect and just use the base wiring.

627 10-06-2017 08:23 PM

Re: 2004 L300 audio wiring
 
Thanks for the quick response, guys! Glad to hear this should be reasonably painless.

[QUOTE=soulsurvives;2256220]Don't forget to hook up the factory amp turn on wire, I didn't at first and thought I was in trouble LOL.[/QUOTE]

Is that one of the normal wires in this setup? Was it just not a good connection at first or something?

soulsurvives 10-07-2017 12:00 PM

Re: 2004 L300 audio wiring
 
[QUOTE=627;2256324]Thanks for the quick response, guys! Glad to hear this should be reasonably painless.



Is that one of the normal wires in this setup? Was it just not a good connection at first or something?[/QUOTE]

I don't really remember. I wired the radio to the harness while I was in the house and when. I installed it in the car I got no sound. I then remembered that the car had a factory amp so I then hooked up the sure needed and I was good to go.

Russet 10-13-2017 09:49 AM

Re: 2004 L300 audio wiring
 
Did you ask Pioneering audio support to ask what other steps or connections to use? They could also provide more sources to your question as well.


All times are GMT -5. The time now is 02:03 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.