SaturnFans.com Forums

SaturnFans.com Forums (http://www.saturnfans.com/forums/index.php)
-   Astra Tech (http://www.saturnfans.com/forums/forumdisplay.php?f=113)
-   -   2009 Astra Diagnostic Error Codes, diagnostic help needed (http://www.saturnfans.com/forums/showthread.php?t=231882)

jarluk 07-16-2017 12:01 PM

2009 Astra Diagnostic Error Codes, diagnostic help needed
 
I have these 4 error codes, vehicle was stuttering at low rev's and had check engine light on.

P0300
P0301

I have changed spark plugs to help with this but no change in performance

P0313
C1555

What are these codes? What is recommended course of action?

Should I invest in a new iginition coil pack?

fdryer 07-16-2017 12:57 PM

Re: 2009 Astra Diagnostic Error Codes, diagnostic help needed
 
P0300 is a general misfire for all four cylinders, P0301 is for misfiring in cylinder #1. If you search past threads within the Astra forums, you may see a repeating failure pattern of coil packs.

Googling for each error code will provide many sites with code definitions.

DWW 09-05-2017 03:58 PM

Re: 2009 Astra Diagnostic Error Codes, diagnostic help needed
 
My daughter has a 2008 XR that has thrown a number of codes including 300, 301 and 313. I have replaced plugs, coil pack, mass airflow sensor and air filter. Car runs great but the CEL was still on. I recently (this past Saturday) cleared the codes and am waiting to see if the CEL comes back on.

j.small17 11-10-2017 11:46 AM

Re: 2009 Astra Diagnostic Error Codes, diagnostic help needed
 
My 09 Astra XE is giving me 0301 and 0313 codes. Running very rough, acceleration is weak, and CEL comes and goes as I drive. Based on a few threads I've read on this site (it's been a big help for me, a new Astra driver) I figure it's either the spark plugs or ignition coils.

I replaced the spark plugs first, to see if that helps at all. The gap was bigger than .045, so I tried closing the gap (didn't help) then I put in new plugs (didn't help either).

Now, I have ordered an aftermarket ignition coil pack (Spectra Premium C-828 from eBay, also avail on Amazon.ca). It should be here in about a week. Will update when it's installed. Hopefully it gets everything back to normal!

Edit: forgot to mention some details on my car. Just purchased in July from a used dealer. 54000 km on it (up to 59K now) and drove like it was brand new. It may have been sitting for a while (lug bolts were INCREDIBLY difficult to get off to change to winter tires and the oil drain plug is seized/stuck) before I bought it.

fdryer 11-10-2017 07:04 PM

Re: 2009 Astra Diagnostic Error Codes, diagnostic help needed
 
P0301 is a misfire in cylinder#1 while P0313 is a misfire detected with low fuel; [url]https://www.engine-codes.com/p0313.html[/url]. Astra members here may have better info. Did you run the fuel tank to close to empty?

Whoever did the wheels and oil may have used gorilla techniques using a pneumatic impact wrench set for 3 million ft-lbs.......... Morons do this in laziness instead of learning what t-o-r-q-u-e [tork] means and using finesse if they insist on using pneumatic impact tools.

j.small17 11-18-2017 05:19 PM

Re: 2009 Astra Diagnostic Error Codes, diagnostic help needed
 
Update: Ignition coil pack arrived yesterday and I installed it today. Car runs smooth and is good as new!

Re: drain plug - it seems like it was just over tightened. Was able to get it off with some TLC from a heat gun and a hammer. The O-ring on it looked dinged up (maybe it was leaking and that was excuse to over tighten) so I replaced it.

[QUOTE=j.small17;2258885]My 09 Astra XE is giving me 0301 and 0313 codes. Running very rough, acceleration is weak, and CEL comes and goes as I drive. Based on a few threads I've read on this site (it's been a big help for me, a new Astra driver) I figure it's either the spark plugs or ignition coils.

I replaced the spark plugs first, to see if that helps at all. The gap was bigger than .045, so I tried closing the gap (didn't help) then I put in new plugs (didn't help either).

Now, I have ordered an aftermarket ignition coil pack (Spectra Premium C-828 from eBay, also avail on Amazon.ca). It should be here in about a week. Will update when it's installed. Hopefully it gets everything back to normal!

Edit: forgot to mention some details on my car. Just purchased in July from a used dealer. 54000 km on it (up to 59K now) and drove like it was brand new. It may have been sitting for a while (lug bolts were INCREDIBLY difficult to get off to change to winter tires and the oil drain plug is seized/stuck) before I bought it.[/QUOTE]


All times are GMT -5. The time now is 08:14 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.