SaturnFans.com Forums

SaturnFans.com Forums (http://www.saturnfans.com/forums/index.php)
-   Ion Tech (http://www.saturnfans.com/forums/forumdisplay.php?f=37)
-   -   No power. (http://www.saturnfans.com/forums/showthread.php?t=203965)

IonTwo 10-19-2014 02:15 PM

No power.
 
Yesterday i was driving and ran of a piece of wood at a top of a hill. i didn't see it coming. And then i started losing power. My car can not make it up a hill at all and doesn't run good it just bounces around. I figured it might of been the 02 sensor so i changed it today and it still runs the same. The check engine light is on... Anyone have any suggestions on what it could be thank you!

2006 ion2 10-19-2014 03:01 PM

Re: No power.
 
How would we have any clue what it is? Get your codes read then come back here with that info.

ruley73 10-19-2014 10:08 PM

Re: No power.
 
[QUOTE=2006 ion2;2099137]How would we have any clue what it is? Get your codes read then come back here with that info.[/QUOTE]

+1 ^^

I don't get the logic of "My check engine light is on, so the oxygen sensor must be bad." Especially in this case, the oxygen sensors are behind the engine, farthest from the point impact with your road debris.

IonTwo 10-20-2014 09:07 AM

Re: No power.
 
I guess you guys are right. I thought maybe someone has the same problem before and could give me some ideas, like what the worst case scenario would be. I will go get the code today and see what it is and get back to you.


All times are GMT -5. The time now is 03:52 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.