SaturnFans.com Forums

SaturnFans.com Forums (http://www.saturnfans.com/forums/index.php)
-   S-Series Tech (http://www.saturnfans.com/forums/forumdisplay.php?f=39)
-   -   98 sl2 (http://www.saturnfans.com/forums/showthread.php?t=140611)

dkhueyjr 06-29-2009 09:21 PM

98 sl2
 
HELP
I have a 1998 SL2
I am losing fuel outy the solenoid ASM-EVAP CANISTER VENT VALVE
installed a new one and same thing! I just put a used motor in this car what could I have screwed up to cause this issue? what controls the vent valve? it is pumping out gas fast... Help me please
:drool:

acman 06-29-2009 09:54 PM

Re: 98 sl2
 
The root cause of this problem may be the coolant temperature sensor and / or a sticking thermostat. Saturn has a bulletin, #05-06-04-049, for a false code p0442. The fix is to replace the coolant temperature sensor and connector - if corroded - and replace the thermostat. It is believed that a misreading sensor and in conjunction with a sticking thermostat that the test for the evap emission system is running at the wrong time and getting false readings.

This bulletin may or may not apply to your situation. Start by checking for stored trouble codes.

adventureoflink 06-30-2009 02:31 AM

Re: 98 sl2
 
dude it's a '98 S-series, wouldn't an ECTS and/or t-stat (195 degrees F) be in order anyway :dizzy:

ssicarman 06-30-2009 09:19 PM

Re: 98 sl2
 
Welcome to the Board.

The coolant temp sensor would have nothing to do with fuel coming out of any solenoid.

Are you talking about the solenoid under the intake manifold?
Are the vacuum lines hooked up properly? All the wiring ok, not pinched?


All times are GMT -4. The time now is 09:51 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.